Waarom kan ik izi.TRAVEL niet op mijn Android-toestel installeren?

De applicatie vereist minstens een Android 5.0-versie. Controleer eerst of er een systeemupdate beschikbaar is.

Feedback and Knowledge Base