Perché non riesco a installare izi.TRAVEL app sul mio dispositivo Android?

L'applicazione richiede almeno Android 5.0. Ti preghiamo di verificare se è disponibile un aggiornamento di sistema.

Feedback and Knowledge Base