Why I cannot install izi.TRAVEL app on my Android device?

The application requires at least Android 5.0. Please check if there is a system update available.

Feedback and Knowledge Base